Slow acceleration problems

  1. Welcome to Scion IQ Forum : Scion iQ Prices, Tech, MPG and Forums – General discussion forum for Scion IQ

    Welcome to Scion IQ Forum : Scion iQ Prices, Tech, MPG and Forums - a website dedicated to all things Scion IQ.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join Scion IQ Forum : Scion iQ Prices, Tech, MPG and Forums today!
     
+ Reply to Thread
Results 1 to 9 of 9

Thread: Slow acceleration problems

  1. #1
    N_A
    N_A is offline
    Junior Member
    Join Date
    Jul 2019
    Posts
    5

    Angry Slow acceleration problems

    Hello everyone! I bought a used 2012 iQ from the Toyota dealership with 90K miles. Since the first day I noticed that sometimes the gas pedal is not responding immediately. The issue gets much worse whenever the AC is running. Sometimes it takes up to 3 seconds to even realize I pressed the gas. It really feels unsafe to drive. My friend with the same iQ drove mine and said that his doesn't act the same way. I did some maintenance trying to fix the problem but it didn't work. Here is what I did so far:

    -CVT fluid change
    -new spark plugs
    -cleaned MAF sensor
    -cleaned throttle body
    -fresh motor oil
    -cleaned accelerator pedal connections
    -ECU reset
    -Idle reset relearn procedure

    Any ideas?

  2. Remove Advertisements
    IQ-Forums.com
    Advertisements
     

  3. #2
    Junior Member
    Join Date
    Jul 2019
    Location
    Dayton, Ohio
    Posts
    4
    Not a professional here but what climate do you live in? CVTs can be adversely affected by warm weather. In addition, if the CVT fluid was never changed before you bought the car, it could have been damaged by the old dirty fluid and as a result no longer drives like it should.

  4. #3
    N_A
    N_A is offline
    Junior Member
    Join Date
    Jul 2019
    Posts
    5
    I am in Florida actually. How can the warm weather affect the transmission?

  5. Remove Advertisements
    IQ-Forums.com
    Advertisements
     

  6. #4
    Senior Member Micky's Avatar
    Join Date
    Mar 2012
    Location
    Vermont
    Posts
    292
    Does it feel like an engine lag or a transmission lag?
    Micky

  7. #5
    N_A
    N_A is offline
    Junior Member
    Join Date
    Jul 2019
    Posts
    5
    It feels like I am pressing the gas and nothing happens for a few seconds: the rpms are not increasing. I just replaced the accelerator pedal and it did not fix the problem.

  8. #6
    Senior Member Micky's Avatar
    Join Date
    Mar 2012
    Location
    Vermont
    Posts
    292
    So it is more like a slow accelerator pedal response more than anything else?
    Micky

  9. #7
    Junior Member
    Join Date
    Nov 2019
    Posts
    11
    Did you ever get this sorted out?

  10. #8
    N_A
    N_A is offline
    Junior Member
    Join Date
    Jul 2019
    Posts
    5
    I apologize for not responding. I quite forgot about this forum.
    No, the problem has never been solved. I just learnt how to live with it. At some point I even replaced the throttle pedal to make sure it was not caused by some faulty electronics.I guess that what I experience as a slow throttle response is just a combination of the little engine, the CVT transmission, and the AC on. Other that that my iQ runs perfectly and I drive it everyday with no issues.

  11. #9
    Member
    Join Date
    Oct 2019
    Posts
    77
    Quote Originally Posted by N_A View Post
    I apologize for not responding. I quite forgot about this forum.
    No, the problem has never been solved. I just learnt how to live with it. At some point I even replaced the throttle pedal to make sure it was not caused by some faulty electronics.I guess that what I experience as a slow throttle response is just a combination of the little engine, the CVT transmission, and the AC on. Other that that my iQ runs perfectly and I drive it everyday with no issues.
    I noticed mine is slow to respond when I just started and pulling out of my driveway, like there is a restriction or something. Once I pulled out, it drives normally. I do not recall it doing this in the winter, so might be indeed the hot temperature, or the fact that I'm driving it a lot less. I'm also thinking of replacing the fuel filter. Now, there supposed to be some lag in response when parking (for safety) and there are devices to eliminate that lag if you like it, e.g.:


  12. Remove Advertisements
    IQ-Forums.com
    Advertisements
     

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please select your insurance company (Optional)

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Powered by vBadvanced CMPS v4.1.2